Input argument in form checks checkbox, but returns an error when trying to submit


I’ve been creating a form where an input argument will sometimes “Pre-check” a checkbox. At first glance it looks fine, but when I try to click submit it fails. Please have a look at the attached screenshot. I would like to make the question required, but no matter if it’s required or not it gives me this error. As far as I’m concerned, there’s only selected one item, so I don’t get the errormessage.
I can solve it by unchecking and checking the checkbox again, but that’s not a sustainable solution for the user.

Can anyone help me out here? Thanks.

Regards Kristine

Hey @krhaes

Please share the project zip here.


The web page may not be properly registering the input of the Check activity.

I would try Click instead of Check. Only difference is you might need to use Get Attribute to verify if it’s already checked, before Click-ing it. Depends on your process logic.

It’s not a check in a webside, it’s a check in a “Form”. So that wouldn’t work. Thanks though.

I changed the checkboxes to Radiobuttons and then the problem was solved. I guess there would still be a problem in trying to pre-check a checkbox in Forms, but for now the radiobuttons solved it and it was fine, since I only had to check one option anyway.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.