Confused by Check activity failing to check

Hi all,

I’m getting very confused and frustrated with the Check activity. I have a program that checks a radio button and then continues to populate the field that shows. The robot is failing when it tries to populate that follow-up field, as it isn’t checking the radio button.

The check ISN’T giving an error, and the selector is still showing as valid.

The workflow contains other check activities - all the ones with radio buttons have the same issue, whilst the checkboxes are operating as expected.

What would cause an activity to think it has worked in this way? What is the solution?

All I can think of is to replace the check with a click and use a try/catch to reclick if it has inadvertently unchecked the box. Obviously this is neither correct nor fast!



If Check activity not working here then try with Click activity once.

@SoqedHozi, I guess the check activity only works for checkboxes. Try click activity for radio buttons. Please let me know if it is working

The description for check activity specifies radio buttons.


The issue with click is that if it is already checked then this activity would uncheck it. I’ve previously had problems with using retry scope and get attribute to avoid this, so wou;ld prefer check activity to actually do what it’s supposed to!

Using click, a get attribute, and an if works, so although it’s not elegant and check not working is going to cause me a mighty headache changing everything it looks like that is what I have to do…

did u check the Check activty Properties

Yes, the selector was valid, the waitforready was interactive and the action was “check”. Nothing else configured.

Using a get attribute I confirmed the action didn’t think it was checking the radio button in error.

I tried using activate as well, but no luck.