IBM Lotus Notes Email automation using UI Path activity is not working


I am implementing IBM Lotus Notes email automation using UI Path “Get IBM Notes Mail Message” activity. Its seem that this activity is having issue.

What I am trying to Do:
Filter IBM Lotus Notes email based on certain text in “subject” and save attachment from those email in specific folder.

What issue i am facing :
I am getting exception from UI Path
Exception Type : “System.FormatExceptio”
Exception Message : "An Invalid character was found in the email header : ‘.’.

My finding while trouble shooting
Under Option Properties (where we have option to choose GetAttachmens & TOP), if i provide TOP =1 then the program works. If i provide any value other than 1, then program throws exception as mentioned above. I tried various option for TOP values, 0, no number , negative number nothing works other than 1.

As TOP=1 is not going to work for me as email will not necessarily be a TOP message.

I looked on forum and tried suggested solutions like Moving email from Inbox to Personalized Folder and set the Mail Folder accordingly in UIPath properties. Its doesn’t work.

Could you please help in providing solution on the issue i am facing?

Thanks & Regards

Hi @praveenkr,
Welcome to the Community!
Could you please provide us more details?

  • Studio Version
  • Mail activities package version
  • .Net Framework version

Hi Pablito,

Thank you for your reply.
Please find the requested information for your reference.

Studio Version : 2018.4.6
.Net Framework Version : 4.7.1
OS : Windows 7 Prof, SP 1, 32 bit
Mail Activity Package Version : 1.6.0

Please let me know if you need further information.


Thank you for this. Is it possible that you could attach the workflow which causes the problem for you? Of course please remove any sensitive data like mail, password etc. And the last thing. Is it possible by you to test this on other computer with the newest Studio Community Version if problem is the same?

Hi Pablito, Thank you for your reply. I checked internally withing my organization, i am not allowed to share any document/file through web sharing. Is there any other way i can provide you information you need to troubleshoot this issue?


Could you attach screenshot of a part of your workflow where problem exist and it’s configuration from attributes pane. And of course please test it on another computer but with Community Edition of Studio if it’s possible :slight_smile: