I can't conect my orchestrator with robot

I can’t connect my robot to my orquestrator. when i try the error “Empty orchestrator api versions” is throw.


i tryed in two diferentes computers with a new studio and robot community edition and nothing.

how i fixe that?

Hi @Willian_Micali

Check this

Ashwin S

I alredy tried this, and doesn’t work.


Hi @Willian_Micali

Try this for the Orchestrator URL… This works for me all the time…

1 Like

welcome to uipath community
kindly try with this url with ORCHESTRATOR URL

also ensure that the machine name here in your robot tray setting and the one you have created in orchestrator with machine tab should be same that is must have same machine name,

and also while creating robot with that machine created check once with the username and domain that we have mentioned while creating robot
for that we can validate that in our machine like go to cmd window and type as whoami and press enter which will give us the domain/username and that is what should be mentioned while creating robot in the orchestrator

–finally allocate that robot to a environment by creating a environment in environment tab

–once all these steps are done then copy the machine key from machine tab and come here to our robot tray and mention the orchestrator URL as suggested and mention the machine key and now connect

Thats all your machine will get connected with your orchestrator

This would work for sure
kindly try this and let know for any queries or clarification
Cheers @Willian_Micali

1 Like

I try again and nothing, same error

and when i instaled the studio the registration not ask my community login.

for the second day i can’t connect

I still see the same orchestrator url. Have you changed it to what me and @Palaniyappan suggested?

1 Like

worked, very thanks @Lahiru.Fernando and @Palaniyappan.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.