I can't click the button Error (Access is denied.)

Hi guys,
I am trying to click the button named “Random Mac Address” from technitium MAC Address Changer. When I use click activity, it can’t select the button. It said I need to run UIpath as administrator. So I run as administrator and I can access the button but I can’t run the UIpath, the error is access denied. And I close the UIpath and run as normal but Click activity which already indicate the button doesn’t work. Is there any other way to click the button?

Click Here to download the software for test(It is only 2.1MB)


Can you try with Click Image activity and check it once.


If none of the click activities will work, you could try sending hotkeys. Try using Tab until it selects the right button, and then enter.

Hi @Lin_Myat,

Try using a Click Text, or the solutions @lakshman or @BenZee suggested. The program you’re using looks pretty dated so it may be best to use hotkeys (@BenZee’s solution). I have had to do this on a system made in around 2000.

I tried but still can’t click the button. Is there any other solution Sir?

I tried that too. But it doesn’t work. Hot key doesn’t work on this software.

I tried it doesn’t work too. Do u have any other solution?

Hey @Lin_Myat,

If hotkeys won’t work in that application, I’d likely move on to trying as many options of selecting and clicking as I could. Have you tried working with the selectors you have for the Use Application activity? Or even adding/changing target methods for the click activity? Might also be worthwhile to change the input modes and see if any of the other options work, if you haven’t tried that already.

Hello @BenZee sorry for late reply. I got fever and can’t even touch my laptop.
I try the cllick like u said but still doesn’t work. I think robot can’t find the button I give to selector. Do u have any other idea?
Thank u for pay attention.


Pls give a try with COMPUTER VISION activities

Have a look on this on how to use it


Cheers @Lin_Myat