Click button not working

Hello and thank you in advance,

I have a button I need to click on a website and it’s not working. I’ve tried click, double click, and click image, all with and without SendWindowMessages or Simulate Click and it appears to click the button but nothing happens. It then moves onto the next piece and this fails. I even tried copying a click button activity I was using just prior and it won’t work on this button either. What am I missing?
This one works further up but not here
1
and this one does not work at all
2
The second image is where I am trying to click and I can’t get it to work

Thank you

Edit: I’ve also tried Click Trigger and Click Text without success. I can even see the hand click on the button but it does not activate

1 Like

I’ve run into a similar issue before.

In my case, the click duration was shorter than the time it took for the application to register that it occurred.

I had to use activities to send a left click keypress (or select element and press the enter key)1, hold it down for ~50ms, and then left up the keypress.

It was a pain, but it definitely got the job done!

Hello mworth123,

Its seems that your are working with a JavaServer Pages (attached java section into the HTML). You can try to install the java extension for UiPath. Just let us know if that solves your issue.

Regards,

Andres

Hi @mworth123

I have also come across this scenario… the approach @chenderson mentioned is something that I used as well…
Also, the other option is to use hot key activities to select the button and press it… this would work too

2 Likes

Hi @mworth123
Try this using computer vision activities

@chenderson - Thank you, can you provide more on this? I know how to use the Send Hotkey activity but how do I send a left click keypress? Can I use the Send Hotkey activity and then press the enter key or Control + Enter?

Thanks for your help

1 Like

@Lahiru.Fernando

Thank you, how do I select the button in a Send Hotkey? How do I press it?

1 Like

Use send hot key activity, then click select element from screen and select the point you want

1 Like

@mworth123 Absolutley, please check out this link and add in a few hundred milliseconds in the DelayAfter property:

1 Like

@chenderson - I tried your suggestion of doing a type into activity, a delay, and another type into activity and it’s not working.
1
Can you see what I’m doing wrong? FYI - For both type into activities the Selector window has Validate as green.

3

Thank you for your help

Can anyone else tell me why this isn’t working?