HTTP Request URL Segments not working

I’ve been trying to use the built in URLSegements of the HTTP Request activity instead of having to assemble the URL beforehand.

In the wizard, the preview URL correctly takes my URL Segment, but in preview or when actually using the activity, it doesn’t replace the segment (see screenshots) .

Here’s the documentation: HTTP Request

To be honest, I can’t see what I’m doing wrong.



Thanks in advance,

@T0Bi you’re not doing anything wrong, it’s a bug. The UrlSegments placeholders only get changed when they’re NOT part of the querystring (hence the trailing slash /), which is wrong in my opinion. I’ve filed a bug report for that and we will see when we will be able to tackle it.


Alright, thanks for your quick answer!

I’ll assemble the URL before the HTTP request for now.

This issue has been addressed and the fix will be out in WebActivities 1.7.0

1 Like

I’m still having the same issue as mentioned in the original question above, using 1.7.0

What do you mean by assembling the url before the http request?
Cause I’ve tried doing that, and it still doesn’t work for me.