HTTP request activity returns status code 0 and empty response, but works in SoapUI

I am getting this same error as found here: Unable to get response from HTTP request activity

I am using the HTTP request activity with basic authentication. When I try it in SoapUI I get the appropriate response returned. But when I run it through UiPath I get a status code of 0, and the response just returns an empty string. Any ideas?

NOTE: in SoapUI I have to check the box for “Authenticate pre-emptively” for it to work - as shown in the below pic - is this the default in UiPath or is there a way to force UiPath to do this? I’m not really sure what this property means but it is necessary for it to work:

1 Like

Hey @Dave I’m seeing the same behavior. My top priority today is debugging this for my project so I’ll keep you posted if I find anything and please do the same here if you make any progress.

@kellen - I just got this resolved last night and forgot to update this post.

So the service we were using required HTTPS. It turns out the certificate that was created did not allow aliases to be used in the endpoint. I realize using the alias/shortname is a bad idea, but the documentation for the service said that was the endpoint to use and I simply copy + pasted.

When I was getting this error my endpoint was: https://ServiceName/api/activity
To fix the error, I simply updated the endpoint to the full URL instead of the shortened one: https://ServiceName.azl.pvt/api/activity

Incredibly simple fix that I just wasn’t thinking of! - so if you know who set up the certificate, you can ask them to verify if that’s the same case for you

Hey @Dave thanks for getting back to me so quickly. I’m glad you resolved your issue. I actually just realized it was a timeout problem for me. I had set my timeout to 6 seconds but I’m uploading large files so the request was timing out. The problem was that the HTTP Request activity is supposed to throw an error on a timeout but it wasn’t doing that so I was seeing the default values for the variables created for the StatusCode and ResponseBody.

I think this is a bug with the HTTP Request activity so I’m going to log a bug with UiPath.


FYI that bug is here: HTTP Request activity does not throw error on timeout

1 Like


I encountered the same scenario, I just extend the timeout value from 6000 to 30000 and it works fine now.

Hope it helps

1 Like

I had the same error - HTTP request would occasionally return blank response and status code 0 - it also turned out to be a timeout error.

Like Jeven, I extended the timeout to 30s and haven’t had any issues

I too am getting an empty response with status code 0. It seems my request is timing out, but i do not understand why. I have tried increasing it to 180s, and yet it still times out.

It is a WSDL, and it works fine in SoapUI and Postman. The url however does not work in Google Chrome browser.
If I set the method as GET, i get the same error as in the Google Chrome Browser (500 - internal server error ), If i set the method as POST it times out.

Any suggestions?

Hi @3-rimo

I know it may be an overkill, but have you tried to create a library out of your web service definition file?
See here:

(I believe it is available in Studio since 2019.4)

1 Like

Thank you for your reply.

I did indeed try to create a library, but I dont understand where I should post my body, or indeed choose the post method. Thus I have not been able to fully attempt this approach.

I wrote a long blog post about the 1 use case of the libraries for Orchestrator API, you could give it a look if you’d like:

If not, let’s focus on the issue here. I would suggest having a look at this topics:

1 Like

It works!
The two latter posts did not solve my problem, but creating a library out of the web service worked when I followed the instructions you wrote.
Thank you so much for your help.

1 Like