How to write complex formulas in excel

Hi, I have an issue that I don’t find in the forum. I need write a complex formula in excel with the activitie “Write Cell”. This activitie works good with simple formulas, but not with complex.

I try to write this in the activitie: “=SI.ERROR(BUSCARV($A1,RA!$A:$F,6,0),”+chr(34)+chr(34)+")"

But when the bot runs, it writes this in excel:
=@SI.ERROR(BUSCARV($A1;RA!$A:$F;6;0);"")

And i need this result:
=SI.ERROR(BUSCARV($A1;RA!$A:$F;6;0);"")

I don’t know why “@” appears in the formula and mess up it.

Really thanks for your help.

Hi @Cristian_Rojo_Casanova

Please check this post might help you,

Thanks
Latika

@Cristian_Rojo_Casanova - I guess its a bug. I have read it in the forum somewhere…Let me find a reference for you…

@Cristian_Rojo_Casanova - This is the one I was talking about…But looks like the bug is in StudioX. Please check this and tag any uipath forum staff if error still persists even after upgrading your excel activity package to Prerelease.

if you are writing the formula using the write cell activity from Studio, that’s a bug and is still investigated.
If you are using write cell from StudioX, should work using latest excel package.
Let me know.

Aparently it’s the bug. I use Studio Pro Community, and the issue persist after update the excel package

is there any other way to handle this?

I try many other ways, but at the moment I don’t have a solution.

I try use .Replace("@",""), copy the cell and paste in other part, system write cell, and more. But the issue persist :confused: