How to Use Invoke Process to Utilise Orchestrator Process

Hello All,

I am trying to utilise the Invoke Process activity that is compatible with 2019.6 on wards according to the documentation (currently running 2019.10).
The problem I am encountering is that no matter what combinations I try I cannot get the activity to find the process(es) within Orchestrator and run them.

Invoke Process: Cannot find a process named ‘process name’

Also tried specifying a folder for a local file but still get below message.

Invoke Process: Cannot find a process named ‘process name’ in folder ‘folder path’

Can someone please provide advice on how I can use this activity and invoke a process named in Orchestrator?

Thank you in advance for your help with this.

Hello @ConrtinueOnError

Have you tried using the Start job instead of invoke process since your processes are in the ORchestrator?

Can you show us a screenshot of how you configured the Invoke process activity and the process information?

1 Like

Hi Lahiru,

Do not think Start Job will work in this situation as the idea is the robot will switch state. Lets call process 1 invoker and process 2 robot. The invoker will run and check for new emails to add to the queue, if the mailbox is empty the invoker is to trigger the robot process and complete one queue item. It will then switch back to being the invoker process and check if there are any items to now process in the mailbox.

Hope that makes sense. Essentially if I used start job it would never switch back to the 1st process the way I desire.

Afraid I do not have an example to hand right now but can confirm I entered below as properties:

Arguments = None entered
Process Name = “RobotProject7”
Folder Path = Blank (when trying local run I entered path to where file was saved in here).

Thank you for your help.

Hey @ConrtinueOnError

There are few consideration to make when using Invoke Process. First thing is, check to which environment your local robot is connected to in the Orchestrator…

For example:

As you see here in the screenshot, my robot is connected to the environment highlighted in the red color circle. It can only access Processes that are published in this environment. So make sure your process and the robot are in the same environment.

If that is in the same environment, then providing the process name should trigger the process through your workflow without a problem… Just like this for example


Let know whether this helps

That did the trick, noticed I was connected to a different environment. As soon as I swapped over to the one the process is against it worked a treat.

Thank you :slight_smile:

1 Like

Awesome!! Glad to hear it worked!! :smiley:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.