How to start a job from Orchestrator to run Robot as Administrator?

I have a situation, where my application on Windows Server always run under Admin privileges. During automation UiPath is unable to perform any actions on my application, if it is not running as Administrator.

I get below error,
Cannot access target process! Elevated privileges might be required. Try running the UiPath application as an administrator.

However changing permissions to all the UiPath executable files (UiPath Agent, Studio, Robot, Service.Host) in “C:\Programs Files(x86)\UiPath\Studio” folder, to “Run As Administrator” for all users by changing the properties for each file, worked when running the job/process hosted in orchestrator from Agent.

But, if I want to deploy and trigger a job from Orchestrator with the changes to UiPath executable files mentioned above, is not letting the job to start; and throws below error in Orchestrator.

Could not start executor. The requested operation requires elevation. (Exception from HRESULT: 0x800702E4)

RemoteException wrapping System.Exception: Could not start executor. The requested operation requires elevation. (Exception from HRESULT: 0x800702E4)

Please help me to solve this situation.

Thanks in Advance.

Regards,
Srikanth

I found the solution from UiPath Support.

To run Uipath service as Admin, we make the below changes in policies:-
Run gpedit.msc to open the Local Group Policy Editor. Expand Computer Configuration, Windows Settings, Security Settings, Local Policies, and Security Options.
- Set “User Account Control: Behavior of the elevation prompt for administrators in Admin Approval Mode” to Elevate without prompting.
- Set “User Account Control: Detect application installations and prompt for elevation” to Disabled.
- Set “User Account Control: Run all administrators in Admin Approval Mode” to Disabled.
- Set “User Account Control: Only elevate UIAccess applications that are installed in secure locations” to Disabled

Thanks UiPath Support

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.