How to renew a orchestrator license?

Hello, my license expire this week, I got it renew last week by the seller, he confirmed its done. When I do

.\Regutil.exe export-info /out_file=C:\Users{my user name}\Desktop\20191129cert.out

I get a txt file, then in the license page, I click on renew and pick this file, but the date don’t update, its still say its gonna expire this week.

Is there anything I’m missing?

if its a enterprise edition kindly raise a ticket on it

Cheers @MaxyArthes

I did, but its take a while to get a reply and I need it renew before its end, in 2 days. So trying to get help here also incase there a quick solution. As of right now, they confirmed my license is extended but I just can’t get it renew on the orchestrator page.

May i know what was the issue you were facing
@Pablito @loginerror
kindly help us on this pls

Cheers @MaxyArthes

I was getting the license txt file using

.\Regutil.exe export-info /out_file=C:\Users{my user name}\Desktop\20191129cert.out

but the date was always staying the same when I was using the “Renew” option on the orchestrator page, I seens a post about deleting the license folder before doing it, so tried, didn’t worked. Copied back the old folder and now when I do the command in Powershell, I got a error:

Error #12: Cannot initialize licensing library: -1089

@MaxyArthes let’s try to debug your issues step by step.

You deleted the license folder from your Studio‌ machine? In order for it to initialize you have to open Studio‌ first.

Second, what Orchestrator version do you have? In order to get the file easier, please use the activation portal for versions 19.4 and lower: Activation. There, in the Activate your license section, fill the license code, select your Orchestrator‌ version and click Generate. This will give you the file with the correct data and you just have to try again in Orchestrator‌.

Let me know if this works for you.


the step you writed is what I did.

Orchestrator 2019.4.4

I tried to use it but its was saying my license was wrong… But the tech support sent me the txt file to update it at the end, saying I had no instance ID to update my own license.