How to queue more than 4 jobs on a single Robot? Error: "The robots already have pending jobs for this Process"


We are currently using the Start Job API for Cloud Orchestrator to start multiple jobs for the same process.

The Issue: Now, after we started 3 jobs with different input variables for the same process, it gave us an error at the third API stating that:
“message”: “The robots already have pending jobs for this Process”,
“errorCode”: 1670,
“resourceIds”: null

We have read about it, and it seems Orchestrator has a limit of pending jobs for the same process on the same robot.

The Question How can we make the robot accept more than 1 pending job for the same process?

Do not start the job using a specific robot as you’ve read there is a limit to the number of pending jobs a specific robot can have. Rather allocate the job dynamically (1 time if your parameters are different for each instance), this will queue the job in the given environment of the processes until a robot is free to pick up the pending job.

The jobs will run simultaneously up to the maximum number of robots available in your environment until all the jobs are complete.

The following document will describe the use case scenarios.


Can you expound on what you mean by this? In the Trigger, I set to “Allocate Dynamically”, but given the Process is tied to an Environment and I have only 1 Robot allocated within the Environment, it still hits the limitation, so appears there is still now way to queue multiple instances of a Job…? thanks

“If you start the same job on the same Robot multiple times, and the first job is not fully executed, only the second job is placed in a queue.”
I thought that by configuring the Trigger to utilize “Allocate Dynamically”, even thought there is only 1 Robot Configured for the Environment, I thought that it would have queued up the multiple instances of the Job (without the 1 Robot assigned) and once the Robot finished 1st instance of Job, then it would pick up the next queued instance and then assign to the Robot at that time? Overall, it is still limiting the number of queued Jobs. thanks

My understanding is you allocate dynamically the individuals jobs are not assigned to a specific Robot until a robot is available to pickup the job. This is what I have observed with multiple Robots in a single environment with a Trigger setup for dynamic allocation. If this is not the behaviour you are seeing, I would open a support ticket to investigate.

  1. If you want to execute a process multiple times on any Robots that are available, you have the possibility to do just that by using the Allocate Dynamically option on the Execute Target tab. The jobs are queued, in a pending state, in the corresponding environment and each time a Robot becomes available, the first job in line is executed. In this way no Robot is ever available while there are jobs pending.
    Let’s say you want to run a process 7 times. The moment your trigger is launched, 7 pending jobs are added to the environment workload, without being assigned to specific Robots. There are a couple of scenarios possible:
  • There are at least 7 Robots available at trigger time - one Robot gets assigned one job such that all jobs are executed in one go.
  • There are less than 7 Robots available at trigger time, say 4 - each of the 4 Robots gets assigned one job, if a new Robot or one of the 4 becomes available, then it takes over another job of the remaining 3. This happens for each available Robot until no jobs are left.


Using the Allocate Dynamically option you can execute a process up to 10000 times in one job.

1 Like

Thanks Tim for the follow-up. I will check with UiPath Support because that is not what I am seeing.
Not sure, but it maybe the fact that I do not have 7 Robots allocated to fun the process 7 times.
I created 10 Triggers that passed in a different Parameter for each instance, but I only have 2 Robots assigned to the environment/process, so not sure why it is not queuing up the Jobs without assigning a Bot.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.