How to open a private browser in Chrome using UI Path

Hi, i am trying to open Google chrome in Incognito mode but when i check the Private checkbox in properties panel, the bot still opens the Browser in normal mode rather than Incognito,

Hi Shailesh,

What Studio version are you using?
In the latest 18.1.0 you have to check the Private checkbox in Options, not Misc.


In 2016 version itself it available in properties Private


Hello there,
In 2016* version this feature used to works for only in IE not for Chrome.
It’s fixed now in 2017.1 moonlight

The Private property of the Open Browser activity is fixed, now working properly and opening Chrome in incognito mode.

1 Like

It doesn’t work in 2016 version , even after I check the Private Option from Properties panel it still opens Chrome in normal mode.

Hi thanks for the update - I am using 2016.2.6274 , so no chance of opening chrome in incognito for this version ?

Hi I am using 2016.2.6274 , tried the same but doesn’t work , any other suggestion ? kindly help.

yes @shaileshpathak, its working in IE browser only not in chrome , if you want you need to update your version.


@shaileshpathak, Probably you can go with CTRL + SHIFT + N - Send hotkeys

Dominic :slight_smile:

@arivu96 - Okay thanks, will do that . Thanks again,

Hi you mean I should send Hot keys to open a private browser for Chrome ?


Dominic :slight_smile:

Hi , in my scenario , I have to open a URL in private session , So the sequence would be - Open Browser - Send Hotkeys- after this should I be using Attach browser , how would I pass the URL to the new Private Session.

@shaileshpathak, I have suggested it as an alternate, if you follow that then proceed with following

  1. Open chrome application (Start Process)
  2. Send hot keys - CTRL +SHIFT +N
  3. Type URL into navigation bar of browser

Note If you aren’t comfort with above solution then upgrading would be a better and concise solution.

Dominic :slight_smile:

I think you can do this. But not sure it works.
Let’s try whether it’s backwards compatible or not :wink: .First make sure to take the backup of your older version of UiPath.Core.Activity .nuget file(you can find here C\Program Files (x86)\UiPath Studio\Packages\ ) then uninstall it from package manager and then download the attached package and follow these steps (see adding your own package section).

UiPath.Core.Activities.17.1.6435.21841.nupkg (548.5 KB)

1 Like

Not able to automate in incoginto tab .UIpath is not supporting. Not able to select elememt.

Did you install the extension? Does it work on non-incognito tab? What Studio version?

Yes it is working in non incognito tab and i installed Uipath Studio version 2018.2.3.

Extension is installed in non -incognito But when tried to check in incognito tab
Below screen came.

Can any one help in this.

@Bharti_sanghmitra , you will need to enable extensions in incognito mode.
Steps you can follow:

  1. Go to Chrome browser
  2. Add the chrome extension(if not added yet)
  3. Goto customize and control > More tools > Extension
  4. Click on the UiPath Extension
  5. Now, allow the extension in incognito.

6. Should work :slight_smile:


Happy Automating!

1 Like