How to increase rdp login timeout value when starting process

orchestrator

#1

We have problems starting a process from orchestrator if vm instance is in log off state.
It seem that the average RDP login time is over 60s which could cause this error

“Executor start process failed, reason System.Runtime.InteropServices.COMException (0x80070520): A specified logon session does not exist. It may already have been terminated. (Exception from HRESULT: 0x80070520)\r\n at UiPath.UiSystemClass.OpenInteractiveWindowsSession(String bstrUser, String bstrPassword, UiOpenSessionFlags nFlags, String bstrApplication, String bstrAppArguments, Int32 nDelayMs, Int32 userToken, UiGenericOptions options)\r\n at UiPath.Core.Setup.OpenInteractiveWindowsSession(String username, String password, OpenSessionFlags flags, String application, String arguments, Int32 userToken, Int32 preferredWidth, Int32 preferredHeight, Int32 preferredDepth)\r\n at UiPath.Service.Impl.Executor.StartProcessInSession(Guid executorInstanceId, String username, String password, OpenSessionInfo sessionInfo, IntPtr userToken)\r\n at UiPath.Service.Impl.Executor.<>c__DisplayClass13_0.<b__0>d.MoveNext()”

Is it possible to increase the timeout value? Robot is having green value anyway in the heartbeat monitor.


#2

Hi,
How about this.
https://www.webfusion.co.uk/support/answers/Dedicated-Server/Windows/how-do-i-set-up-the-timeout-options-for-remote-desktop-connections-2078/


#3

Please check this topic: Config RDP timeout to create user session

Let me know if it works.


#4

Link says i don’t have access to it?


#5

So it should be possible in theory to start process even if we have logged out the robot ad vm session?
In this scenario we are trying to start UIPath Studio dev robot, is there limitations with the studio robot?
According to documentation only 443 is necessary to be open between orchestrator and robots.Do we need to open rdp port also?


#6

try now


#7

Thanks! Now i can access the article. So the latest version


is required to use the new parameter.


#8

Tested with 2016.2.6442 seems to fix the issue. Didn’t receive the error after setting longer timeout in the robot vm instance.