How to ignore files in UiPath with a .gitignore file the correct way?

Hello Friends,

I am using git for version control. I want to ignore certain folders such as .local, .settings and cache files etc when storing and tracking on git. I have used github desktop options to ignore them. In other words, I didn’t write the .gitignore file by hand. I had github desktop do it for me. Even after that, the folders and the files are not being ignored and being stored on github.

What am I missing?

Can some one show me a correct sample .gitignore file?

More on how to use .gitignore here.

Hi @savantsa I have had the same issue. Check your online repo as these old folders are already committed into it. You will want:

  1. Remove your current gitignore file. This is so we can clean up your remote environment

  2. Delete the .settings and .local folder for all your projects. Don’t worry, this wont break anything as when you reopen the project they will auto generate

  3. Once all local and settings folders are deleted, commit the changes and push to remote to reflect these in your repository.

  4. Update your .gitignore to the two lines I list below. You can use any text editor for this.

.settings/
.local/

Cheers and stay safe brother

Yes. That worked. Thanks Bro!

Stay home, Stay safe!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.