How to GetText dynamically from webapp

selector
studio

#1

hi

i have webapp
for example: consider Student records, each student having 1 different page…

Q) if i open 1st student page i need to capture (Student name) and
again if i click 2nd student page again i need to capture (second student name) dynamically

pls help me…


#2

Hi @Venkatp,

If your selector is changed everytime you click on a student, I think you need to use dynamic selector to get desired text.

Regards,
Hoang Anh.


#3

its working fine
thank you very much


#4

Can u share ur workflow as it will helps others.


#5

Main.xaml (8.4 KB)

i tried it in google page itself -


#6

Try this…!!!


#7

I tried to use the ‘Dynamic Webpage Link.xaml’, but getting the following errors.

scrape has thrown an exception

Source: Open https://www.google.co.in/

Message: Cannot communicate with the browser, please check the UiPath extension.

Exception Type: BrowserOperationException

UiPath.Core.BrowserOperationException: Cannot communicate with the browser, please check the UiPath extension. —> System.Runtime.InteropServices.COMException: Cannot communicate with the browser, please check the UiPath extension.
at UiPath.UiBrowserClass.Open(String bstrURL, UiBrowserFlags flag)
at UiPath.Core.Browser.Open(String url, Boolean privateSession, Boolean headlessSession, Boolean defaultSession)
— End of inner exception stack trace —
at UiPath.Core.Activities.ScopeActivity.EndExecute(NativeActivityContext context, IAsyncResult result)
at UiPath.Core.Activities.AsyncNativeActivity.BookmarkResumptionCallback(NativeActivityContext context, Bookmark bookmark, Object value)
at System.Activities.Runtime.BookmarkCallbackWrapper.Invoke(NativeActivityContext context, Bookmark bookmark, Object value)
at System.Activities.Runtime.BookmarkWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)


#8

Hi @hindsfeet,

Do you have chrome installed?. In the workflow, the BrowserType is set to Chrome.
image

There are two instances when I faced this error :

(a) The Browser Chosen in Browser Type isn’t installed on my system
(b) When Browser Type is set to IE, on Windows 7 machine in which I didn’t have admin rights in the system. When I tried using a windows 8/8.1/10 machine I didn’t face this issue.

Hope this helps!

Kudos! :slight_smile:

Thanks,
Nithin Prabhu


#9

Thanks. I had chrome installed. it didn’t work. I just changed to Internet explorer.
Thanks for your help.