How do I put the secure string password to the get email activities

email
security
activities
studio
password

#1

I use Windows Credential Manager to store the login and the password to log in to gmail. It returns a security string in password, let’s say, “sstr_password”. When I use the Get POP3 activity, it requires a string as the password, hence I can’t simply put “sstr_password”. The way “sstr.password.ToString” also doesn’t work as the exception of login failed shows up. How do I do it correctly?


#2

Hi @MGMKLML, you might want to convert your secure string to string .
String s = new System.Net.NetworkCredential(String.Empty, sstr_password).Password;

Hope it works. :slight_smile:


#3

@quihan yeah thank you it worked :slight_smile:
Could you also please tell me how to properly configure the IMAP thing?
I always get an exception like the host is unknown: 0x800040005


#4

@MGMKLML, Looks like there’s something wrong with your configuration. Did you insert the right Port and Server ?


#5

@quihan, I tried the ports: 143 and 993
The server is: "“imap.google.com


#6

Are you using the Get IMAP Mail Messages activity? Port 993 and Server “imap.gmail.com” should work fine.


#7

@quihan, Yeah I’m using this activity :frowning: And I enabled the IMAP thing in the settings. And you can access from less secure apps. And the Get POP3 activity works fine.


#8

@quihan, found out that I put imap.google.com instead of imap.gmail.com


#9

Haha. Hope its working fine now.


#10

@quihan, Yes it is :slight_smile:


#11

Sweet. Happy Automating :slight_smile: