Help! Invoke Python Method: One or more errors occurred

Hi,

I’m new to python and I’m trying to invoke this script, but i keep getting the “one or more errors occurred” error and I’m not sure what the problem is.

the code is:

from pyresparser import ResumeParser
data=ResumeParser(’\path’).get_extracted_data()

I’m sure it’s probably the code itself but i just need someone to assist me with figuring out the issue.
Thank you in advance!

@Tariq_Al-Hajri

Welcome to the forums

It’s really difficult to assist you with just the error message

It would be good, if you upload your workflow and required dependencies
So that we can help you

Thanks

Hi @Tariq_Al-Hajri ,

Could you let us know at which Specific Activity does the Error Popup ?

@Tariq_Al-Hajri Did you tried to execute the python script before integrating in UiPath?
It’s better to try this code in any IDE( SPYDER,JUPITER etc) and cross check the python code is valid.

Thanks for the reply. its a simple process that i just wanted to test out. i’ve tried changing my version of python and changing the activities version with no luck.

BlankProcess1Template.zip (35.6 KB)

Hi @supermanPunch
the error occurs after i invoke the python script. it loads fine and i tried changing the script around a bit to make it work, but still nothing.

Hi @Rahul_Unnikrishnan
the script works well on Jupyter but after i tried to execute it on uipath i get that error. i even tried using a simple script just to see whether or not it was my code and i still got the ‘Pipe is broken’ error.

Please watch the below video. It can solve your issue.

@Tariq_Al-Hajri ,

Could you Change the Python Code to the below and Check :

def GetData():
    from pyresparser import ResumeParser
    data = ResumeParser("test.pdf").get_extracted_data()
    return data

In the Workflow, make the Below Highlighted Changes :
image

Let us know if you receive a Different Error from Before or if it worked out.

Hi @Rahul_Unnikrishnan
Thank you i will check on it and follow up later!

hi @supermanPunch

i appreciate the assist. unfortunately, after applying the changes i am still getting the same ‘Pipe is broken’ error. could it be cause the data i am importing is too large?

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.