HELP - Bug - container keeps expanding, so App is "frozen"

Hi, @evan.cohen etc.

Not sure how to actually explain this, so please see attached gif. I litterally cannot do anything in the App. It just never stops. I think it started when I moved an image into a container?

What can I do? I have tried to clone the app and export/import, but the issue persists!

Can I roll back to a previous publish? How can I save this App I have spent many hours on building?


Hi @stch ,

Could you try exporting, deleting and importing the Apps which you have created and see if that resolves the issue?

If you could share it with us, I could try importing it into my instance and see if the error replicates - provided you don’t have an issue sharing it on a public forum.

Meanwhile I’ll see if I can find anything useful.

Kind Regards,
Ashwin A.K

Hi @ashwin.ashok

It did not help exporting, deleting and import. New import has same issue.

Robot Assistant Dashboard.uiapp (2.1 MB)

Here it is. Anything to get it fixed :slight_smile:

Hi @stch ,

It kept expanding so I wasn’t sure what the issue was and decided to add a text element into it.

That just accelerated its expansion, and now its expanding so fast that it started to make the universe jealous.

I’ll look into it some more, but what I’ve noticed is there are several containers getting created, but due to some technical issue, it all comes under Container1.

Starting to look like one of those Math problems I used to run away from

I hope this provides some insights into the Product Team as well when they decide to have a look at it.

Kind Regards,
Ashwin A.K

Thanks a lot for your help so far @ashwin.ashok

I tried all sorts of things, including just leaving it to see if it eventually stops. But at some point my browser just gets a stack overflow error message instead.

Hope the Product Team can fix it somehow.

Hi @stch ,

I figured it out, but I wasn’t able to generate the Visual Tree on the Left.

Click on the Container1 and head over to Size

Both fields were set to Auto, and I passed in 800px and 100px into Width and Height respectively.

Robot Assistant Dashboard_PartiallyRecovered.uiapp (2.1 MB)

Still, its a product bug and we’d really appreciate it if you could notify the team on this @evan.cohen !

Kind Regards,
Ashwin A.K

Hi @ashwin.ashok

Thanks for your effort. To me it seems like it is still creating containers like before, and because there are hundreds containers or more (I guess) it is why the tree view is gone, because there are too many.

Hi, anyone who has any ideas here?

On Monday I need to present this app and due to this error I cannot publish it. So I’m a bit stuck here.

Anyone who knows what to do in this case?

Is it possible to copy the functionality to a new app without exporting/importing?

Maybe it is possible for the Product Team to remove/correct the containers which are causing this directly in the .uiapp file?

Hi @stch I see that the Container has a child that is the Container itself. We are not sure how the app reached such a state ideally a container cannot be dragged inside itself. It would be great if you can shed some light on the steps you followed right before the app got messed up.

Hi Bhavana,

To be honest I’m not sure what I did or how it happened. I managed to fix it by deleting the container (something I have tried 100 times, but suddenly it worked), so now the issue is gone.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.