...incompatible with project's language

Hi again,

I’m back with this problem because I tried everything you suggested and it still occurs.
Considering that I migrated from legacy to windows, is it possible that it is a bug from them because they are not ready with all official UiPath activity packages in Windows?
I specify that the robot is running fine.


Hi @anamariavioleta.dinca

Check this:


Hi @supriya117

Faced similar issue recently. Tried the solution suggested by @supriya117 which resulted in failure to load project in studio.

Sadly there wasn’t a quick solution :frowning: The bot’s were relatively smaller so we created new process in studio & copy pasted the bot activities into the fresh process.

If the option we followed not feasible to you, can can always check with UiPath support but it will be lengthy process.

Ashok :slight_smile:

1 Like

Hi @anamariavioleta.dinca

Try to change the language in project.json as suggested by @supriya117

Also, before migrate others projects to Windows, check and disable C# as default language in Desing settings if it is enable

1 Like

If after what you said you get the error “Expression Activity type ‘CSharpValue`1’ requires compilation in order to run. Ensure that the workflow has been compiled” for any activity, you must rebuild the activity that throws this error.
Then it works.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.