Having trouble linking activities in flowchart

I reviewed suggested issues and searched but found no previous post.

I am working on the random number generator to guess a number between 1 and 99 There are two assign activities in this process but there seems to be no way for me to drag a connector per the instructions.

This is the flowchart example.

2 Likes

@Marc_Crenshaw
Make sure that you are inside a Flowchart activity container. The connectors won’t appear otherwise.

in the design tab of studio click on NEW and search for FLOWCHART and there use the assign activities and we can drag on moving the cursor near to the border of assign activity where we get like this
image

from here we can drag a connector

hope this would help you
Cheers @Marc_Crenshaw

Thank you for the help. I am not sure why my assign activity won’t give me the link I need. Your help was great though. Thanks for taking the time.

Also, if the connector is already going to another activity, it won’t let you create the connector. Basically, you can’t have two connectors going out to two activities.

If you provide a screenshot, it might be easier for someone to identify the issue.

1 Like

Here is my file. I can hover over the item but cannot get an edge to attach the line. If you want to correct my language please do I am still learning the correct terminology for items. Thanks in advance.’

I see the problem. There are two arrows on the bottom left Assign, meaning you have 2 lines already. What you need to do is click on that second arrow that is facing up but not going anywhere, and hit the delete on it to get rid of it, and that should free it up so you can draw the line out to another activity.

Thanks let me try that and if all is lost I think I will start from scratch. This is all part of learning and as a result maybe I will be a better troubleshooter myself in he end.

Hi Marc have you resolved this issue? I am experiencing something similar today with flowcharts…trying to drag connectors from other nodes of the activity and I am unable to. I’m also only able to connect via the bottom of the activity and not from the sides. Didn’t know if this was a known issue with the newest version?

Can you show a screenshot of your activity? His screenshot was able to show what the issue was, because it had an arrow coming out of the activity already, which in that case you would need to delete that arrow first.

Clayton, thanks. I am going to start from scratch to better learn the process and I will make the adjustment you recommended.

Marc

Hi,
I started from scratch and was successful with my robot coding. I do not have any answers on known issues. This is week two using UiPath and RPA. I am sure the community has answers though.

No problem. Just to clarify what I am looking at is shown below:
image

You would need to click on that arrow pointing upward and delete it. I’ve done this before, I think

No worries @Marc_Crenshaw - I feel silly even asking this question :slight_smile:. But for whatever reason I couldn’t connect activities today like normal. Decided to do a search and see if this was a known issue and found your post.

@ClaytonM thanks for weighing in. Here’s a screenshot of one of my flowcharts. If I hover over the “Start Log Message” activity I can see the small rectangular images that indicate where you can click and drag a connector. When I attempt to drag one from the right side of the activity over to the “Test Setup Sequence”, I am unable to. It only works if I do this from the bottom node of the activity box. The same is true for all the activities on my screen. image

I am using 2019.7.0 Community Edition. If this is not a known issue then it’s obviously on my end; it just seems random because I’ve not seen this before and I am on UiPath full time right now. I’ll do some testing within another environment to see if it happens there also. Please do let me know if you have thoughts on what’s going on here.

1 Like

Tried in a different environment and it’s not happening there. That was with 2019.4.3 Enterprise Edition.

Never feel silly for learning.

Not sure, but maybe it glitched. Have you tried remove the arrows and starting the arrows again?
image
I noticed a gap on this arrow, which seems like maybe it’s messing something up. There should be no gaps like that.

Yes, I tried removing arrows and starting them again. No luck. It’s not a show-stopper since it’s on my local machine with Community and not production.