GSuite - Send mail - Changing attachment type and name

Hello everyone,

I am sending email using GSuite integration - the problem is that when I add any attachment - in my case it´s image and send it - the attachment arrives with a name “noname” and no file extension.

If I download the attachment and add extension “.png” I can see the image.

The problem is that when you open this email on your phone you will not see the image preview and you are unable to open it unless you download it and rename it.

Any idea how to fix it? I have confirmed that I am providing right file name - path + fileName + extenstion.

Thanks, Eduard

1 Like

Hey @Eduard

Could you please print that filename and show us please…

Also kindly show how are you attaching the image please ?

Thanks
#nK

Hey, this is the file I am receiving:
image

And this is the workflow:



1 Like

Hey @Eduard

I can see you are passing something on the Attachments List as well as the Attachments parameters right ?

You can just pass the attachment in any one of those please…

Thanks
#nK

I am passing only the list

1 Like

Okay @Eduard, Thanks for the confirmation.

What I think is you image file is getting attached as inline image…

Can you just attach some text file or PDF file please to confirm this behaviour. Just do a test run please

Thanks
#nK

Thanks for reply,

I tried the same thing with .txt file and it behave just same as image. So it is un-relevant what kind of file I am attaching.

Thanks,
Ed

1 Like

Hey @Eduard

I can see you are passing a relative path, Kindly try passing the full file path once please and also from the Attachments parameter instead of raw array.

Also, Kindly let us know which version of activity package you are using.

Thanks
#nK

Hey, I tried also the attachment parameters instead of a list - still the same.

Problem can not be in path since file is attached to the email - the file is correct it is just renamed in the process.

Thanks, Eduard.

1 Like

Yes you are right, But just try once please.

This will help us to troubleshoot in a different way.

Thanks
#nK

Hey, I tried with the full path - still the same
Thanks, Ed

1 Like

Hey @Eduard

Your save image activity is saving the file correctly right… Hope you validated it…

Thanks
#nK

Hey, yes it is, in the local folder I can see all files correctly named with extension.
Ed.

1 Like

Thank you @Eduard for raising this.
We’ll look into fixing this with the upcoming release.
Meanwhile, please consider using as alternative the activities from UiPath.Mail.Activities package: Use Gmail → Send email.

1 Like

it is fixed in the Version v1.16.1

1 Like