Gsuite application scope : An error occured while sending the request

Hi,

I am facing gsuite issue while sending mail,change labels, reading gsheet using gsuite application scope.

Error message : An error occurred while sending the request.

Can anyone faced this kind of issue previously?

Hi @Sailaja_Pasupuleti

Kindly check all “Service Account Key” inputs are supplied correctly and choose correct Authentication Type for your account.

Hope this will be useful. Thank you.

We are using oauthclientid. Authentication is successful but facing issue in gsuite application scope. Using 1.11.0 version

Can you upgrade it to 1.13.2 and try again?

image

Thank you.

Tried that option as well. Issue not resolved permanently. Intermittently facing issue

Try to increase ‘TimeoutMS’ property.

Sometimes the internal API calls might be sending request/responding to the request slowly due to bad internet bandwidth as well.

Thank you.

sure will increase the timeout property in Gsuite application scope. 60 sec is ideal time or 120 sec?

I suggest to keep this value in config file so that we can change it anytime whenever needed.

Initially try with 60 seconds.

Thank you.

@Jobin_Joy - Still I am facing the same gsuite application scope issue.

Can anyone help me on this?

Can you please share some detailed information like screenshot/sample flows?

Thank you.

I am unable to provide screenshot as issue occurs in production and also unable to reproduce it local environment.

It is throwing generic error message
Gsuite application scope: An error occured while sending the request.

Gsuite package version : 1.13.2
OauthClient : UiPath
Timeout MS : 60000

Hi @Sailaja_Pasupuleti

Can you add a log like in the below screenshot to get the error source and share here?

Thank you.

Please find the detailed error message

Exception occurred in GSuite application scope : System.Net.Http.HttpRequestException: An error occurred while sending the request. —>
System.Net.WebException: Unable to connect to the remote server —>
System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time,
or established connection failed because connected host has failed to respond xxx.xxx.xx.xx:443
at System.Net.Sockets.Socket.InternalEndConnect(IAsyncResult asyncResult)
at System.Net.Sockets.Socket.EndConnect(IAsyncResult asyncResult)
at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Exception& exception)
— End of inner exception stack trace —
at System.Net.HttpWebRequest.EndGetRequestStream(IAsyncResult asyncResult, TransportContext& context)
at System.Net.Http.HttpClientHandler.GetRequestStreamCallback(IAsyncResult ar)
— End of inner exception stack trace —
at UiPath.Shared.Activities.AsyncTaskNativeImplementation.BookmarkResumptionCallback(NativeActivityContext context, Object value)
at UiPath.Shared.Activities.ContinuableAsyncNativeActivity.BookmarkResumptionCallback(NativeActivityContext context, Bookmark bookmark, Object value)
at System.Activities.Runtime.BookmarkCallbackWrapper.Invoke(NativeActivityContext context, Bookmark bookmark, Object value)
at System.Activities.Runtime.BookmarkWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

Hi @Sailaja_Pasupuleti

If you have trouble in send email using gmail even after given correct inputs like port and server.

Please following the below instructions in the case gmail.

  1. Go to the Less secure app access section of your Google Account. You might need to sign in.
  2. Turn Allow less secure apps on.

Kindly note that, this setting is not available for accounts with 2-Step Verification enabled. Such accounts require an application-specific password for less secure apps access.

For such a case, you refer the below,
https://support.google.com/accounts/answer/185833?hl=en

Hope this will be useful. Thank you.

Hi @Jobin_Joy,

Should I follow below steps for Read/send mail using OAuth with GSuite activities?

Please following the below instructions in the case gmail.

  1. Go to the Less secure app access section of your Google Account. You might need to sign in.
  2. Turn Allow less secure apps on.

The above one you can try for getting the error. The setting you have set for your google account in order access google account through a third party application/component.

Thank you.

Looks like issue with network latency. UiPath team confirmed the same. Hence checking with our infra team.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.