I am getting exception while bot try to access the folder “Could not find a part of the path”


But the folder is available

Hi @sruthesanju
Incorrect path: Make sure that the path you are providing is correct and valid. Check for any typos, extra spaces, or incorrect slashes.

Retry: S:\abc\03022023


Everything is correct

HI @sruthesanju

If this path is something like sharedrive

Use the Network path and check once again


I have used network path

And same result?

Yes same result

If i run again it’s working one time is working and another time not

Hi @sruthesanju,

which activity are you using?


Folder exits activity

Hi @sruthesanju ,

Could you let us know in some more details the Implementation done to achieve this ? You could provide us what you have used/done in Steps so that it will be more clear. If possible do share the screenshots of the workflow.

I have given the parth in asset see the path exits if exits it will not create folder if not it will create folder

Have you modified the path type to folder ? @sruthesanju

Also the below expression will check for the folder exists or not



I have used folder exits activity UiPath.core.activitirs.folderExitsX

Okay use a message box before and check whether the path is printing correctly or not and try with the above expression once @sruthesanju

Hi @sruthesanju,

Could you share the screenshot of the activity and also mention the input you have given to the activity.


If i run manually means it is working if i run with trigger it’s not working

Hi @sruthesanju,

are you running and triggering it both in the same machine or are the machines different?


I am running both in same machine