Uipath robot error: Could not find a part of the path XXXXX

Hello everyone!!

Can someone help me with this error?

I have a problem when I try to execute my robot from orchestrator.

When I start my job it finished quickly because there is an error that says “RemoteException wrapping System.IO.DirectoryNotFoundException: Could not find a part of the path XXXXXXX” however, In my project I don’t reference to that path.

Also, if I try to run process from uipath assistance (in different machine when I developed robot) there is a label than mentions “awaiting install” and if I click in option install it marks the same error that in orchestrator. In summary, I can’t run my process neither from orchestrator nor uipath assistance. I can just run my project from machine I developed it.

-I already changed all invoke workflow path in order to write full path

-I tried to disconnect and connect again

-In my uipath assistance, it shows as connected.

I don’t really know how to solve this, I wish I found the solution

image

Status uipath assistance connection

image

Hey @cesarcu0990

Could you please confirm if the file is project.json ?

Thanks
#nK

@cesarcu0990 Welcome back to uipath community

I guess file path which you mentioned is not having full path

No, Error makes reference to a directory no a file

But that path I didnt use in my robot

Is that directory used in the robot or is that a dir with project files ?

Also I hope your user has access to the C folder nuget where the packages are saved.

If you don’t show us the path, we can’t really understand what it’s trying to do.

image

image

from orchestrator

D:\RobotsFiles is a local path that doesn’t exist, or the file Derivacion.de.Primas doesn’t exist. Or your user doesn’t have permissions to that folder.

These are the only things that cause this error.

This is not any kind of path that UiPath uses. It’s something you created and you are indeed referencing it somewhere in your code. Show the activity you have that’s trying to access this folder.

@cesarcu0990

Solution 1: In Dictionary variable(ex: in_Config) you might have hard coded this path you have mentioned. Or in the Config file you might have specified. {Key , Value} pair
So check your Config file and the in_Config variable.

Either you use the file path or not, somewhere you have hard coded, so its causing this error.

Solution 2: also check the access for that path, if its a test server or PROd server, this path might not be having authorization.

Solution 3: Do Single step, you can easily fix it

thank you for your answer.

the strange things is that it happened with any project,
It always shows the same message error, the only different is the project name.

image

Ok, can you run it on your dev machine, with single step, you can find the root cause.

also

  • Close UiPath
  • kill all the instances of UiPath from the task manager
  • Now open it
    Dont run from assistance
  • single step
  • disconnect the assistant and reconnect it to Orchestrator
    Check your assets, if you have added any values there.

Hi @cesarcu0990 !
Not sure if there is a relation, but maybe you stocked at D.… packages ?
Would you mind checking in the settings of your manage packages and uncheck if you see that path ?

Are you having an Invoke workflow activity in the impacted process?


Possible solutions:

  • Update UiPath.System.Activities package to the latest stable available version

  • Update the Robot to 2022.4.4

  • Give access to Everyone with Full control for D:\RobotsFiles and its subfolders

  • Modify in uipath.config file (in Studio installation folder) this line from <add key="disableSecureXaml" value="False" /> to <add key="disableSecureXaml" value="True" />. Then restart UiRobot service in services.msc and retry the old behavior.

  • Rename the packages folder to packages_backup from .nuget\packages path (the installation path of your downloaded packages) and rerun the flow from Orchestrator if the robot is installed in Service-Mode