Getting problem in Git Init(Could not find part of path)

Dear Forum members,

When i try to connect to git , i am getting this error

Can anyone help , its urgent .

Any suggestion will be appreciated.

Thanks and regards
Sahil Garg

Dear Members,

Any suggestion ?

Dear members ,

Any suggestion , anyone ?
Please help

I’m encountering this problem as well. I’m using Studio Pro 2020.10.2 and whenever I try to perform a GIT Init or a commit, I receive the following error message:

Could not find a part of the path 'C:\Users\[username]\Desktop\BlankProcessTestAgain\_git2_a12948'.

This happens on any project; existing ones, or new blank processes. I encountered this from the first time I tried to use the Git integration in Studio.

Another thing to note is that attempting a GIT Init on any project in Studio places a shortcut in the project directory (named something like _git2_a12948). This shortcut does not lead anywhere that I can find. When I click on it, I get a “Location is not available” error.

Any help?

Hi mate,
This question is from my old Id .
Still not got solution for that.

Forum members, any suggestion please if anyone can help ?

I have verified with @Charlie_Davis that we are running the same version of UiPath Studio Pro 2020.10.2 Community. I do the same steps to create a new project and do the git initialize and I do not get any errors. Also I do not see any folder/shortcut trying to be created. Is there something else added on or installed that is making it try and create this link ?

I have found this article https://github.com/libgit2/libgit2sharp/issues/1726 which appears to be related to the root cause of this issue. I do not know how to upgrade this library if it is being used by the core part of UIPath Studio. Still not sure why it would only effect only a few people so something else has to be different on your systems. @Charlie_Davis @Sahil_Garg1

Hi @Sahil_Garg1 and @Charlie_Davis , could you please help us with the following details?

  • Could you please run a DiagnosticsTool report and attach the .zip file generated to this thread or send it to me via private message, if you feel more comfortable? You need to search for the UiPath Diagnostics Tool from the Windows Startbar, and just follow the wizard.image
  • Could you also please mention what OS (exact version would help) and .NET version you are running on?
  • Are you maybe using some other GIT tool deployed on your workstation? If yes, what is it?
  • Do you have the Microsoft C++ 2015 Redistributable x86 installed on your workstations?

@Sahil_Garg1, what action were you performing when you got the error?
Thank you so much for your help!

Hi,
Am Trying to use Git version control system, but getting this error.

Please find the Diagnostic Zip file.
DiagnosticToolExport-24-Nov-20.zip (1.9 MB)

1 Like

Hi @Sahil_Garg1, I was referring to what actions from GIT in particular - I noticed that you had a project opened in your screenshot above - were you maybe trying to switch branches? commit something? just opening a project under GIT? or the same GIT init action reported by @Charlie_Davis.
Also, thank you so much for the DiagTool. I browsed through the logs but it seems that there is no GIT error in the Studio.logs. Could you kindly perform the action you trigger the error with, then run the DiagTool again and attach it here? It would greatly help us in our debugging purposes.
Again, thank you :slight_smile:

1 Like

Hi,

Yes, I was Trying Git Init to connect to Git.

Please find new DiagnosticZip FileDiagnosticToolExport-24-Nov-20.zip (2.0 MB)

Thank you for you help.

1 Like

Thank you so much, @Sahil_Garg1!