Getting error on running the Robot saying 'Value cannot be null. Parameter name:Value'

Getting Popup message saying ‘Value cannot be null. Parameter name:Value’ on running my Robot. Not sure if I am missing anything.

Hi @sanket.thatte,

The value you’re printing is empty. Or Your variable or argument is not passed correctly. Can you check the source of the error message to identify which activity.


Can you share your workflow file or more information about the error? This seems to be a variable or an argument, most likely missing argument

are you able to trace your activity where the error popes up

Hi, click the import arguments on the your invoke workflow and pass the variable.

Hi, I encounter the same problem.
I have no idea how to trace the root cause since the error message only shown when I run via the Robot. It doesn’t show if I run from the Studio.

Anyone have idea how to trace the root cause?

1 Like

I’m having the same problem/error.
If I try to call the process through UiRobot, the same error appears, and with a simple test workflow.
I’ll share the workflow:

Hi All,

I’m able to solve this problem by killing the UiPath Robot from the task manager.
Hope it helps.

Was this ever resolved? Im having the same issue and Im wondering if its a permission issue. I have a simple workflow that has no parameters and Im running the bot using AD so dont think I need to pass a password

Ok so from Orchestrator back to your local environment you have to provide credentials.

I have a similar problem. “Value cannot be null -Parameter name: String”
Can someone help me please.
I attached the log and the xaml here.

Estou com problema semelhante. “Valor não pode ser nulo -Parâmetro nome: String”
Alguém pode me ajudar por favor.
Coloquei anexo aqui do log e do xaml.Select_Acsel_Copy.xaml (28.3 KB)

I am having this exact problem. But not when the Robot runs. I get it when I’m trying to place any activity into any part of a “Try Catch” Activity. It just says “value cannot be null (Parameter ‘value’)” - I don’t know what to change. Every YouTube video shows it working no problem for each Tutor demonstrating how “Try Catch” works.