Getting error Could not load file or assembly ‘UiPath.System.Activities’

Have this issue that I can’t figure out. A process that has been published and running on the same robot for months all of a sudden started throwing this error.

Tried checking for the basic, like does it exist in orchestrator feed, does it exist in the multiple .nuget and package folders in the VM, all good.

Tried copying the npkg file directly to the folder in Studio\Packages and the .nuget\packages folders that existed.

All good but process till doesn’t run on that one machine.

Important to note it runs file in other machines/robots and I tried via orchestrator trigger and doing remote debugging and same result.

Anyone came across this that has any thoughts?

Thank you,

Hi @jeffsilva

Please check on below thread


Hi Lakshman,

I did scavenge the forums for other posts and found that one and a couple others but nothing that works for me.

Thank you for the effort.


Follow up,

First of all this was a background process so when running it was using NT Authority\Local Service to process.

On a hunch I deleted the folder for that specific library in C:\Windows\ServiceProfiles\LocalService\ and reran. Noticed the process was still error but not referenced a different library.

I then deleted all folders and reran, the process redownloaded the nuget packages and ran successfully.

I wonder if this was an issue with files being corrupted or a folder permissions change, perhaps on a system update, as I have other in the pass similar errors due to that error.

Hope this helps someone else.

Thank you,


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.