Getting a table from excel without knowing where it starts

Hi everyone
I’m trying to get a full table from excel but I don’t know where it starts.
It can start in the A column, but also the B column, and also in the second or third row…
I tried the “read range” inside an “Excel Application Scope” but it gave me the first row that doesn’t have any data in it
Example:


and it disrupts my work…
thanks in advance

Hi @dlichtenstadt,

For the Read Range activity specify range as —> ""

1 Like

it is like this ("")
and it takes the first rows and columns as well.
I tried once with the actual range (I inserted the starting cell in this example: “B3”) and it took the Exact table!! (can’t put in the range for permanent use because I don’t know if it will stay always the same)

There’s a possibility that, a cell from 1st row contain white space " ".

2 Likes

Hello,

Well if you can’t know where the table starts, the better you can do is retrieve the entire table (with the first row header option unchecked) and after it, put an filter datatable activity for remove all the “empty” rows.

For the automation purpose, it’s a must to have the same data structure for each file, but if you can’t, you have to handle it manually. The read range activity is not magic and can’t decide if this row is usefull for you, it just retrieve the data you asked to retrieve :slight_smile:

2 Likes

OK
I just checked what u said, and deleted all the row data and it worked it gave me only the required rows and columns

for some reason I don’t have this problem anymore…
thank u very much

thank u very much
if i will have a problem like that i will do this option…
thank u

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.