GET text without using "aaname" and "idx."

Hi Guys.

Hi bro need your help, i have a grid so i want to take the text from each cell .
Note:its not a table i cant able to do data scrapping. so here i have the only option that i can take the value by row by row…

one more tricky is the idx values are not unique …its keep on changing …so i tried many ways but because of the idx chages and aaname changes i cant able to get the proper solution.

so here i just thought that is it possible to get the text without using aaname and idx…

please revert i keep on trying it so far.

Thanks,
Suresh.

is possible ? try to use anchor

@suresh_kumar4 Can you use a two Click Activity on two of the rows and Open the Selector in UiExplorer and Validate the Selector if not. Then Send the Screeshot of both the rows Selectors. This is done to understand the relation between the two rows, so that we can use a Loop and extract all data if they are related in some way.

Instead of completely removing idx and aaname, try to find the part in the selector that remains constant every time and for the part which is dynamic and changes every time, replace it by “*”. Also, try Validating your selector with uiExplorer.
Hope it helps!

1 Like

thanks @anupama.bhardwaj for your quick response…

I tried this but when i replace image then when i try to highlight its highlighting the whole window.its doesnt helps.

Thanks.

thanks @supermanPunch,

Here my idx values are keep on changing for every refresh of the webpage…

1st time to the 1st row the idx value is 1 after refreshing its chaning to idx=5 for the same cell…
so this also i tried but no luck.

Thanks,
Suresh.

@suresh_kumar4 Can you send the Screenshot of the Selector Validated in UiExplorer ? :sweat_smile:

@suresh_kumar4 Can you replace the second line in the Selector with the line below and check if the Selector gets Vaidated.

<webctrl parentid=‘pvExplorationHost’ tag=‘DIV’ isleaf=‘1’ tableCol=‘1’ tableRow=‘1’/>

okay! sorry its not validating

its a grid … not a table thats why i am not not row and columns.

If the aaname values does not change every time, you can keep it as is. And only keep “*” for idx.
Also, as suggested by Suresh add\ isleaf= ‘1’.

1 Like