Get row item error: "StringConverter cannot convert from System.Double"

Hello

I am new to using Excel and UiPath together.

I am getting the following error when reading integers in a Datatable from Excel:
“Get Row Item: StringConverter cannot convert from System.Double.”

It can read the cell above which has ‘123t’.

I believe the problem is reading ‘123t’ as a string but reads ‘123’ as an integer.

Any ideas on how to make it read all values as a string?

Error - Activity screenshot:
image

Error - Output screenshot:
image

DataTable screenshot (the red cell is where UiPath is getting stuck):
image

2 Likes

@Steven_McKeering, Hi

Try this: In your excel file select the column “Keyword
Right-click and select format cells… and then select text. save and try again.

This will make excel to treat everything in that column as plain text, let me know if that helps:

Format cell

Hey

It didn’t work for me. Thanks for the suggestion.

Same error message: “Get Row Item: StringConverter cannot convert from System.Double.”

Mind sharing your workflow?

Here it is.

Main.xaml (7.2 KB)

Any assistance is appreciated :slight_smile:

Oh and the reference list is attached

Topic Reference List.xlsx (17.0 KB)

@Steven_McKeering

My brain is overheating :hot_face:, but I solved it.

Let me know if it works fine.

Example1.zip (29.2 KB)

1 Like

Nice work.

Have a drink on me :tropical_drink:

1 Like

I also had the similar issue. I was unable to implement the solution discussed here in my work but I was able to find a solution that worked for me.
You could change the Variable Type of your main variable where the error is occuring to a generic value (UiPath.Core.GenericValue).
Hope it helps.

4 Likes

Thank you, this solution worked also.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.