Get IMAP Mail Messages activities results in error

I’ve been following the demo in the academy for the foundational developer course and I’m currently stuck in making the Get IMAP Mail Messages activity working. Basically it results in the following error message:

Get IMAP Mail Messages: An error occurred while attempting to establish an SSL or TLS connection.

This usually means that the SSL certificate presented by the server is not trusted by the system for one or more of
the following reasons:

1. The server is using a self-signed certificate which cannot be verified.
2. The local system is missing a Root or Intermediate certificate needed to verify the server's certificate.
3. A Certificate Authority CRL server for one or more of the certificates in the chain is temporarily unavailable.
4. The certificate presented by the server is expired or invalid.
5. The set of SSL/TLS protocols supported by the client and server do not match.
6. You are trying to connect to a port which does not support SSL/TLS.

See for possible solutions.

Here is my configuration:


So I’ve already setup an App Password and that’s what I used in the password property. Not sure why it’s still not working. I’ve also tried the following:

  1. disabling my antivirus and firewall but still the same error.
  2. Tried all SecureConnection property options.
  3. Tried changing 993 to 143.
  4. Tried the Less Secure Connection instead of the App Password.

Please help. Thanks


Check below for your reference


Hope this may help you


Yep, saw that already.

I’m starting to think that it’s a connection problem from my computer to the servers since I can’t add both my gmail and yahoo account in outlook. Maybe some of you have experienced this problem before? Thought it might be a blocked port or something but nothing happens even after terminating my antivirus and turning my firewall off. This is making me rage! :triumph:


Are you behind any VPN / Proxy, If so you can disable that and try


No VPN or proxy.