Formula Error as end of expression expected

I aim to put the following formula into an Excel Cell (E4) with the function “Write Cell”, by which I can perform Vlookup with data from another Excel file (EC_Policy (as at Mar).xlsx). However, Uipath couldn’t recognise the formula as it said end of expression expected. Could any help check what is missing? The formula itself is fine… Many thanks!

“=IF(IFNA(VLOOKUP(VALUE(E4),‘EC_Policy (as at Mar).xlsx]Sheet1’!$A:$A,1,FALSE),)=0,” “,“EC”)”

Please check the double inverted commas, better to use an assign acitivity for storing above formula and then using that variable in Write Cell

1 Like

The formula itself is correct and can be used in Excel, just that it shows error when used in Uipath to perform such an activity.


As you can see the Double quotes and Single Quoates are different.

Please Copy paste the formula in Notepad and replace the Doubel Quoates/ Single Quoates again and then use in uipath.


1 Like

I just tried to copy this into Notepad and re-type and copy back to Uipath but still cannot solve it.
Capture1 Capture2

Okay , So I also Tried Copy paste from notepad - I got the same Error, But then i removed the first and the last double Quote and Re Type them it worked .

PFB screenshot

Try Correcting the Quotes in Uipath


1 Like

Hi @wth1993,

Can you try using this:

"=IF(IFNA(VLOOKUP(VALUE(E4),'EC_Policy (as at Mar).xlsx]Sheet1'!$A:$A,1,FALSE),)=0,"",""EC"")"

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.