Find First/Last row Activity - Excel. Error, output variables not found

StudioX 2020.10.7. Academic ALliance License.
Updated Excel Activities package to 2.11.4

I can’t seem to get output from the saved variables from the 'Find First/Last row Activity.

I tried changing the names both from the designer and properties panel.
From the data manager, it seems like there exist saved values.

But I was trying to test and couldn’t even get it to insert into a message box or excel activities.

Not sure what’s wrong here.


What you can do is , create 2 interger variables(for eg: a,b). Put a in the "Save First row number as " field and b in “Save last row number as” field. Set the scope of the variables as the sequence.

Then in the message box us: a.ToString

It should work.

I also have issues with this action, im sure its not working as it should.

Hi, I’m trying out StudioX right now, don’t see the variables panel.
From the screenshots, the variables FirstRow and LastRow was created.

The 2nd screenshot shows that from the popup menu, it doesn’t show that I can use those saved values.

I tried changing the names, clearing etc a few times. did not work.


Please check in the Datamanager. If you have created the variable you should able to see there.
Same as below.

Hi Rahul,
Thanks for your help. I have checked and it is there.
I think the issue lies in the academic alliance version of UiPath I have on my laptop.
I have tested it on another pc with the community version and it is working.

@caelynl Good to hear that :slightly_smiling_face: