Find Element: Activity timeout exceeded

I have a process that works normally when I run on my machine, but when there is no person logged on to my machine, and I schedule the same process to run at a certain time, it returns an error in the find element

I had the same problem with typing and clicking activities but I solved this by checking the “Simulate” box

Can someone help me?

image

What kind of help do you need, you say you already solved this…

I was able to solve the problems I had with activities related to click and type, but I am having a problem now with the activity “FIND ELEMENT”

Use element exists instead…

Hey @Mths_Teixeira,

Find Element will only find elements in the foreground, so if anything opens in front of your desired element, it won’t find it.

Or do what @bcorrea has suggested and try using Element Exists and alter the timeout to a desired length

1 Like

@william.coulson Thank’s for answer

in this case, I use the find element, to ‘wait’ for the program I use to load in full, as I cannot be held hostage by the Delay, is there any other activity that can replace this ‘wait’ for my program to be fully loaded?

Hey @Mths_Teixeira,

This is what I would normally do

image

The PageLoaded variable is boolean, and goes in the output of Element Exists. Set the timeout to 500 milliseconds, and it will check every half a second to see if the element is there.

There are probably more elegant solutions, but this works for me

1 Like

Thank’s men, I will test today in the afternoon but I think this is I needed!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.