"File" tab selection is not recognized

I receive this message:

I’ve tried SimulateClick and not, neither works. I don’t think I would want to Click an image here, because I’m wanting to convert a .xlsb file to a .xlsx so I have to “Save As” and need the File functionality to work.

Thoughts? Thanks,

either 1) your selector is not working or 2) your selector is working but you did not attach the right window

Thanks Gary.

Any ideas what would cause my selector not to work? I’m fairly certain I attached the right window.

Hi @Bill.Hodde

Could you include some more details:

  • Studio version
  • UiAutomation package version (from package manager)
  • Windows version

Studio version 2109.3.0 - Community edition.

Windows 10 Pro Version 1803

I am not sure how I check for UiAutomation package version. Thanks for your help.


Hi @Bill.Hodde

You can make a screenshot of your Package Manager here:

Is it by any chance a virtual environment?

Also, could you try running this project? The expected outcome is for it to open Notepad and type in “some text”:
TestTypeInto.zip (22.5 KB)

Here’s the screenshot of Manage Packages:

Here is the error message I receive when I run the project you sent me:

Interesting, all is up to date. Could you go over this list of topics and see if any solution works for you?

Each thread will have a post marked as a solution to your error message of:

Please report back. You can also try to reinstall Studio first to have a clean start.