File is in use

activities
error

#1

Private: Write range: The process cannot access the file ‘C:\Users--------\AppData\Local\Temp\53957aac-e9f6-40f0-9e21-49b504ae689d’ because it is being used by another process.

This error is coming while running the program in new version of uipath(18.4.3)
Previously it was running


#2

Hi @AJISHA_P,

Try after killing the application in task manager as the process will be running background.


#3

I did that. Actually excel is not open. and i killed every processes.
Still this error is coming


#4

image

This is the thing that i am getting


#5

Can you try opening the same sheet from different location other than temp folder.

May be in another drive :).


#6

I am trying to open this file from another folder only. not in this folder.
Actually this is a temp file that will be automatically created while we opening / reading/writing the excel.
After that this temp file will be deleted automatically.

But now while running this process it is not getting deleted automatically.


#7

Yeah i know that thing :), i thought you were running the process from that location.
Have you tried restarting your machine and if the file exists in the temp still, delete it manually.

Hope this helps


#8

I restarted my system many times.
And i manually deleted the temp files. but still it is not working


#9

look into it once :slight_smile:

Hope Dev team will look into your problem


#10

i checked this. But this can’t give a solution


#11

And the problem is the same process is running properly in another machine.
So can anyone tell that what may be the issue


#12

@AJISHA_P Can you attach your workflow?


#13

@AJISHA_P what is the UiPath.Excel.Activities pack version? Is is the same as the one you have on another machine?


#14

It must be open , try renaming the filename in “write range” activity and write it.
or
other reason is if u use multiple bot to access one excel this error occur.

if not worked , please tell the prior action you are performing before writing in excel sheet?