File used by another process

Hello all,
I had an weird error like this(File is used by another process) while deleting a file , I have used kill process → Delay and still having the same error
i had also checked with the Get processes activity and loop through all the running processes but there is no excel in that Collection, Any other things we can do to overcome this issue?

@Palaniyappan @ppr @lakshman @Srini84 @Nithinkrishna



Place that KILL PROCESS activity right before the activity where you are trying to access that file again

make sure you are selecting on user level in KILL PROCESS ACTIVITY

Cheers @Sudharsan_Ka


Can you share more details such as which type file and/or workflow etc.? The process might be UiPath itself.


Hey @Sudharsan_Ka

Kindly show us some snaps and where are you using that file before deleting it and what operations you are performing on it if any ?


It is a Excel File @Yoichi

Basically it is like a template it copy from source to dest and rename the file and the datable will be written there

This is the brief of the process @Nithinkrishna

Add small delays between copying file ,renaming and writing datable data to the excel @Sudharsan_Ka

Yes Added that too @Lak_Ui


@Sudharsan_Ka Are you trying to delete the file inside excel application scope???

If yes use Delete file outside of excel activities and try. Also at the same time if you are getting the error, just try to delete the file manually as well.

No Delete file is outside the excel scope and the file it getting deleted when tried manually @Rahul_Unnikrishnan

As you have confirmed all the excel process are killed and not using the delete file inside excel scope. Can you try to restart your machine and try it once.

If still not working try to update all the project dependencies and try to execute the flow. Hope no other services or process are utilizing this file.

Okay @Sudharsan_Ka

After you are writing the DT you are trying to delete it, is that correct?


Yes @Nithinkrishna , Inbetween it will get the values and send mail

How are you doing this step please ?

@Sudharsan_Ka if u use any workbook activity inside a excel application scope of same file it will throws an error like it is used by another process. I experienced it a week ago

Okay Thanks all of you , Actually the error is from mail activities ,it failed to connect to the Clients Server. So this is were the problem occurs if iam right.
The Mail activities are using those files


1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.