Facing issues accessing the url returned by /api/v1/openapi/automations/{id}/documents

I’m trying to get the documents attached to the Idea in Automation Hub using the APIs.
We are able to list them with /api/v1/openapi/automations/{automationId}/documents.

This returns URL for the document in response which is mostly an azure blob storage link. when trying to access it , getting following error

AuthenticationFailed Server failed to authenticate the request. Make sure the value of Authorization header is formed correctly including the signature. RequestId:******* Time:2022-05-05T10:43:46.5535139Z Signature not valid in the specified time frame

Does anyone have any idea on how to fix this?

1 Like

Hey @saurabh_lawange

So you have necessary access ?


Hi NK,

I tried with different user roles like standard user, system admin, but no luck.

1 Like

Okay @saurabh_lawange

You are trying this in postman ?


tried with Postman and Chrome both

Hello @saurabh_lawange ,

Can you refer to the below post.

Hello @Rahul_Unnikrishnan ,

No issues calling the APIs, it is returning 200 OK response.

when i call api/v1/automations/{id}/documents API, its returns URL where the document is actually stored in response.

I’m trying to access that URL and its throwing the error as mentioned earlier.