Extract Data Table Not Working

Hi All,

I am trying to extract the structured data from a chrome browser which is having around 4000+rows.

By using Data Scraping from the studio, I am able to get only 24 rows.

The page does not have multiple pages to get complete data.

After I realized that to use get text activity to get the amount column by incrementing the row number, and added to a data table by using add data row, which worked perfectly up to 24 rows, after that the row number value changed to 1 again. So, the robot failed after the 24th row.

Would someone please help me to completely fetch the records from the table?

Thank you so much for your kind help in advance.


Hi @vishnuaddagada

I think maybe the data on the page is distributed and loaded for reducing the load on the server.
When the page is pulled down, the data below is actually loaded.
You can try to pull down a little of the page and extract data to verify my guess.

In this case, it can only be handled page by page down, and need to correctly judge when the page reaching the end , it is very difficult to keep the process stable.
Another option is to add some filtering conditions, such as limiting Transaction Date, to ensure that all data on the page is loaded every time.

1 Like

Hi @wusiyangjia,

Thank you for your quick reply.

You are correct the page is not stable and hard to extract the data.

Already tried with the page down option but still, the control is not working on the table form.