External Applications feature - Confidential application

Hi All,

I have tried following instructions mentioned in Accessing UiPath resources using external applications documentation. But during testing in Postman the only response that I am getting from API call is:
{“error”: “invalid_client”}

I am sending Post request to:

With Body:
grant_type: “client_credentials”
client_id: “client_id”
client_secret: “client_secret”
scope: “OR.Queues.Read”

And Header:

Values for client_id and client_secret were retrieved from:

Am I missing some configuration or service?

Hello @bromanenko!

It seems that you have trouble getting an answer to your question in the first 24 hours.
Let us give you a few hints and helpful links.

First, make sure you browsed through our Forum FAQ Beginner’s Guide. It will teach you what should be included in your topic.

You can check out some of our resources directly, see below:

  1. Always search first. It is the best way to quickly find your answer. Check out the image icon for that.
    Clicking the options button will let you set more specific topic search filters, i.e. only the ones with a solution.

  2. Topic that contains most common solutions with example project files can be found here.

  3. Read our official documentation where you can find a lot of information and instructions about each of our products:

  4. Watch the videos on our official YouTube channel for more visual tutorials.

  5. Meet us and our users on our Community Slack and ask your question there.

Hopefully this will let you easily find the solution/information you need. Once you have it, we would be happy if you could share your findings here and mark it as a solution. This will help other users find it in the future.

Thank you for helping us build our UiPath Community!

Cheers from your friendly

I met the same issue. @loginerror Could you help take a look ?

Hi @bromanenko , If your external application is for Application scope, the body shouldn’t be like this. you should make it with x-www-form-urlencoded

@Donna_Zhang I tried that as well with similar results.
Did it work for you? can you please add all information if it did?

Did you make sure that your external app scope is Application scope instead of the User scope ?

It was always in Confidential application scope (If I am not wrong, App secret wouldn’t exist otherwise). I moved payload to:
And reentered client secret and client id and it worked…(Could have sworn that I tried sending similar payload before posting this is the forum)
@Donna_Zhang Thanks for all of the help and guidance!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.