Export to PDF command is failing


I am trying to resolve the Export to PDF command is failed but not able to resolve. As I have verified the URL as well in the logs.
Main.xaml (44.5 KB)

Can you check it?


Can anyone help me ?

@Palaniyappan @lakshman need your help guys as I have followed below steps and not able to understand what am I missing.

—use a assign activity like this
arrFiles = Directory.GetFiles(“yourfolderpath”)
Where arrFiles is a variable of type array of string

—then use a For each activity and pass the variable arrfiles as input and change the type argument to string in the property panel of for each loop

—inside the loop use Word package that go to design tab → manage packages → in official tab search as UiPath.Word and install that package

—now coming back to studio inside the loop use Word application scope and pass the input as item.ToString
—inside the scope use a activity EXPORT TO PDF where mention the file path to be saved with
This will convert all the word document in a folder to pdf files

Also have checked the path of Export To PDF

I am waiting for your response. Kindly suggest me to resolve this problem.

1 Like

May I know the error you were getting and at which activity


1 Like

Command Failed error message (Export To PDF) is showing. Even I have checked the path as mentioned in the above screen-shot. Also I have attached main file for rectifying this issue.

@Palaniyappan: Is any solution?

I have tried everything at my end but didn’t find any solution.

1 Like

Kindly have a view on this

Cheers @Dipanshu


I have already created a folder where all the pdf files will be move. Even a single file also not exporting in pdf. Getting the same error. Is any more package required for executing this command.
You can view my attached main file.

Attaching the main file for exporting the single doc file to PDF. It is showing the same error.

Path.zip (19.0 KB)

@Palaniyappan: I catched it and resolved it. Actually the issue wasn’t related to workflow. It was that PDF option was not in the Save As Option List. I downloaded the exe file for PDF and now it’s working fine. Thanks everyone :slight_smile:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.