Executor start process failed error

robot
robotservice

#1

We tried to run a workflow from windows task scheduler and after that we coudln’t run any other script from UiPath (even a simple project with a messagebox"Hello")

The error returned is :
Main has thrown an exception
Message: Executor start process failed, reason Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))Exception Type: Exception
System.Exception: Executor start process failed, reason Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))
Please suggest us what needs to be done.


How can I fix this problem : UiPath.Executor operation is stoped message
#2

Hello,

thank you for your inquiry.

does the computer has admin privileges? can you start the task manager as admin try out. I only had problem with restricted computers.

Happy automation :sunglasses:: if you found the answer of your question pleasae mark it as solved.


#3

hi, im having same problem, how to fix?


#4

Hi johny,
i guess this is a problem with community edition.
for the issue i disabled the windows task after which the workflow executor started working perfectly.


#5

Hi
I’m having the same kind of issue can anyone help on this
Main has thrown an exception

Message: Executor start process failed, reason System.ArgumentException: Process with an Id of 7592 is not running.
at System.Diagnostics.Process.GetProcessById(Int32 processId, String machineName)
at System.Diagnostics.Process.GetProcessById(Int32 processId)
at UiPath.Service.Impl.Executor.set_ProcessId(Int32 value)
at UiPath.Service.Impl.Executor.<>c__DisplayClass13_2.b__1()
at System.Threading.Tasks.Task`1.InnerInvoke()
at System.Threading.Tasks.Task.Execute()
— End of stack trace from previous location where exception was thrown —
at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at UiPath.Service.Impl.Executor.<>c__DisplayClass13_0.<b__0>d.MoveNext()


#6

did anyone find a solution/cause?


#7

I’m facing this issue regularly . I tried customer care they couldn’t help . They told to reinstall which also didn’t solve the issue.

It’s really annoying issue for me. Sometimes I have to click on run the code for 10-15 times to run the code. Uipath team couldn’t help me.

In avg I’m clicking atleast 100 times on this OK button on this message box.


#8

Yes UiPath support team suggested to reinstall the application but still having the same problem.


#9

if you are using a 2016.2 studio version, please confirm first that you have read this topic if running task scheduling
@legendz and @Pravallika can we have more details please?


#10

Hi

I’m using studio 2016.2 only. But this issue happens when we develop the code and click on Run or F5 or Debug. The code will not start running and stops with a msg box telling some process is not running. I have to try multiple times to make the code to start running.


#11

screen shot please.


#12

Hi Gabriel i’m using the version of 2016.2.6274 and through task scheduler i’m able to run the complete task when i’m trying the run the task from studio i’m facing this issue.


#13

ok, so lets take them separately
@legendz

  • please clean up the Event Viewer - Application logs , Studio logs from C:\Users\YOURUSER\AppData\Local\UiPath\Logs and run the code again, gather the newly created logs, zip them and attach them here
  • try with a simple workflow, like log message or message box only activity, does this work?
  • what OS do you have and whats the dotnet version. are you administrator on the test machine?
  • is your Studio version up to date (do you see an update notification in Help?)
  • are you using Community or a registered Studio version

@Pravallika
-what are you trying to run and what`s the exact error you are seeing? uploading here the workflow might help.


#14

Hello.

I had a similar problem before. In order to run any workflow you need the UiPath Robot service to be running. You can define a User Group that doesn’t have rights to start the UiPath Service. I mean that the service will not start at all due to security and the user themselves don’t have any rights in terms of Starting and Stopping Services. You can test it by going into the services and see if when you are trying to run a workflow if the service is started. If it’s not try to start it manually. In my case you couldn’t start the service so I have used this tool from Microsoft to give Start/Stop rights to certain users.

Hope this helps.


#15

please find the screenshot.


#16

@Cosmin_Ion_Nicolae: Hi UiPath Robo service is starting automatically when the execute start process errors comes i’m just closing the error message and rerunning the task and its working


#17

Any updates?


#18

The UiPathRobot Service is not starting automatically when you start the process.

What it is starting is a UiPathRobot process. It may take more time for that to start therefore the error. To avoid it make sure that the service is started (Windows->Services).

If you’re using CE there is no service so it may be an antivirus related problem (the process has a very slow startup)


#19

I get the exact same error message as OP - using community edition.


#20

I am new to UiPath and was trying to run my Simple Hello World from Orchestration and I got the above mentioned error. I’m inside company network and I didn’t gave the password here. As soon as I entered my system password it worked