"Execute Query "-Job stopped with an unexpected exit code 0xE0434352


Hi, I am trying to display data from MS SQL table to Uipath using “Execute query activity” , and writing the data to the Excel (Workbook activity).
I tried to debug it , and it passes the “connect” activity and during “Execute query”, it executes for long and comes up with the above error.
Also, I tried with minimising the data chunks using "where condition "in order to check if that works. But that is throwing the same error as well.

Hi @Nishanthi_Sankar ,

Try to test your connection First.
Make sure after putting user id and password the test should be successful.

Thanks.

Thanks for responding Manoj, Yes it said, test connection was successful .

can you share the select query?

Make sure table name should be same as it’s case sensitive in case of MS sql

I first tried the Query in ms sql and it gets executed without any error.
I am copying the same queries from ms sql and pasted it in the “Execute query” activity.
Hope this helps?

1 Like

Hi @Nishanthi_Sankar
Here is the sample workflow.

account_id.xlsx (8.0 KB)
Main.xaml (6.0 KB)
RepDB.xlsx (7.9 KB)
Let me know if you face any issues.

Hi Gokul, I am getting the attached error from the workflow. “Missing activity”

Also, I am facing error during


the "Execute query "activity.

@ermanoj3101 Is there anything else I can try from my end?

Let’s try to run simple query as select * from tablname for test purpose.

Not sure where exactly the issue is but still try once.

I tried like you said with a simple table with 6 columns and 13 rows and that got executed.

do you have permission to access that db ?

Also please share the screenshot again I just want to verify the screenshot.
I believe you have put the query in double quotes.

Hey @Palaniyappan, @prasath17, @ppr , can you please help her if you have some insights on this issue.
Thanks.

1 Like

Hi @Nishanthi_Sankar
Install the Uipath.Database.Activities and check it once

Hi Gokul,
Yes I have the database package installed.

Check with the workflow.
Let’s try to run query in MY SQL once and check it

Yes Manoj, I have given the username and password for the Db while establishing the connection.
Regarding the Query, I have placed it inside double quotes only.

can you send me the whole query if possible as i can see only “select J.[TenantId]” in screenshot ?

Thanks.

Updated the query screenshot above, Thank you.
The query works fine in ms sql.

2 Likes

Last try, can you increase the timeout of non execute query activity, just give around 500000.
May be query is taking long to retrieve the result but it failed due to default timeout 30000.

When you usually search this query in sql how much time it is taking ?

To execute the complete query, it takes 6 minutes to display the result.
When you said to increase the timeout, did you mean the “Execute query” activity that I have used?

Yes exactly, just increase the TimeoutMS to 10min.