Exception is not catched

Exception is getting caught when single statement is written inside try block but not for sequence of statements.

Hi @Sus_Mi ,

Welcome to UiPath forum,

Inside a try catch the flow jumps to the catch block immediately when there is an error in any one particular activity. If you think the flow should CONTINUE with remaining steps other than that one activity separate them into two try catches and handle the exception accordingly.


No the the exception is still not catched. I tried with try catch within try block but the exception is not catched

When series of assign statements are present in try block , if the first assign statement throws an error the exception is not catched. In this case what should I do

What was the exception type in the catch

Included system.exception so it shld catch all exception nah

you can see from here


Hi @Sus_Mi,

We had a similar issue before where the try catch block in the Process Transaction stage in REFramework did not cat any exceptions originating from the Process.xaml.

As you noted this bug occurs when you use a sequence of activities in the try block. We used around 2 hours with two developers to find resolution or workaround.

The concrete solution to this issue is unknown as there are no logs of the exception in the log messages either.

You can try this. Delete the contents in the try block and also delete the try catch. Close UiPath and build your workflow again or ensure you copy your sequence before deleting.

What worked for us : we had to copy the contents of the Process.xaml file to a new file and delete the Process.xaml file.

Hope this helps.

Hi @Sus_Mi ,

I can see that you are running the flow in debug mode… in debug mode process will show the reason for the exception before continuing with the next step in the catch,


use Run File activity to see the general flow of the bot



Thanks Krishna!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.