Excel Read option is taking too much Time

I’m running a process which contains an excel file of at least 10000 lines. So whenever I run the process, the excel read option is taking too much time( more than 8+ hours). Previously it didn’t take time like this. For this my bot it running slower than before.
I’m thinking about changing the excel file format if it helps.

@nibir08

For 10,000 rows it won’t take that much time. Could you please check with Excel Workbook activities and then try once.

I processed 7k lines task before but back then there was no problem. I just recently faced this problem.
the process is already in production

Hi @nibir08

Are you using excel application scope or the workbook activities to read the file?

Is this happening in only production environment? How about the development machine?

I’ve used excel application scope and read range activity. When it was in development phase it worked perfectly fine. It also worked fine in production phase too. But recently I’ve faced this problem in production phase. One thing is that it happened when I activated the studio license to enterprise edition.

Hmm
Fine
Kindly reactivate the license and try once pls
Cheers @nibir08

1 Like

sure I’ll try to do that and let you know

1 Like

almost same as our problems. but our problems are not only limited to Excel activities. work fine in development machine but as slow as turtle in production machine :frowning:

did u find any solution?

Not , I m looking for solution as well. the last option is to refresh the server and reinstall studio/orchestrator .

The problem was solved by refreshing server and changing excel file. May be the process was too heavy for the system.

Are you using Workbook or Excel Application Activity scope…?? I have also faced similar kind of issue that time I was using Workbook activity in Process flow. For 10*10 data It was taking around 4-5 Minutes. I have changed the Activity from Workbook to Excel and It was working fine.