Excel “printer setup” popup

When processing so many excel sheets.
Excel app scope visible = false
Sometimes this “printer setup” popup is appear.
The rpa process won’t continue until i click cancel or choose the printer in the popup.

How to disable this popup in windows 11 & windows 10? This is annoying.


Hi @wija

Try below thread

Hope it works!!

Hi @wija

  1. Make sure that a default printer is set in the Windows operating system. If there is no default printer set, Excel may prompt you to select one every time it attempts to print. To set a default printer, follow these
    a. Open the Windows “Settings” app.
    b. Go to “Devices” > “Printers & scanners.”
    c. Select the printer you want to set as the default.
    d. Click on the “Manage” button, then select “Set as default.”
  2. Make sure that Excel’s printing settings are properly configured to prevent any unwanted prompts. To do this:
    a. Open Excel.
    b. Go to “File” > “Options.”
    c. In the Excel Options window, go to the “Advanced” tab.
    d. Scroll down to the “General” section.
    e. Ensure that the “Ask to update automatic links” option is unchecked.
    f. Click “OK” to save the changes.

Hi @wija

  1. Open the “Control Panel” on your computer.
  2. Go to “Devices and Printers.”
  3. Find the printer that is causing the popup and right-click on it.
  4. Select “Printing Preferences” from the context menu.
  5. In the “Printing Preferences” window, look for an option like “Quick Print” or “Print directly to the printer” (the wording may vary depending on the printer model and manufacturer). Check this option if it is available.
  6. Click “Apply” and then “OK” to save the changes.

This setting should disable the “Printer Setup” popup for the selected printer, and your RPA process should no longer be interrupted by it.

Please note that the steps may vary slightly depending on the printer model and the printer driver software installed on your computer. If you can’t find the exact option mentioned above, look for any settings related to “Quick Print” or “Print directly to the printer” in the printer preferences.

Keep in mind that disabling this popup means that the print settings might not be applied when you print from other applications. However, since you are running the RPA process with Excel Application Scope’s visible property set to false, it suggests that the printing is not a part of the automation workflow, and therefore, disabling the popup should not affect the process.


Hi @wija

Use a parallel activity and use the excel application scope is one branch and the activities to click on the pop up in the other branch. It will handle the pop up when it occurs.

Check the below to how to do the sequence.

Hope it helps!!

Hi @wija

  1. Open the Windows Control Panel:

    • In Windows 11, right-click on the Start button and select “Settings” > “System” > “Printers & scanners.”
    • In Windows 10, right-click on the Start button and select “Control Panel” > “Devices and Printers.”
  2. Set a default printer:

    • In the “Printers & scanners” or “Devices and Printers” window, find your preferred printer (the one you want to use as the default).
    • Right-click on the printer and select “Set as default printer.”
  3. Remove unwanted printers (optional):

    • If there are any printers you don’t need, you can remove them from the list to reduce the chances of the “Printer Setup” popup appearing. Right-click on the printer and select “Remove device.”
  4. Restart your UiPath robot:

    • After making the changes, restart your UiPath robot to ensure that it recognizes the updated printer settings.

By setting a default printer, the “Printer Setup” popup should no longer appear when using the Excel Application Scope with visible set to false in UiPath. The robot will use the default printer settings and proceed with the automation without interruptions.

Hope it helps!!

My default printer in windows setting is “let windows manage my default printer” = ON

Now i change the default printer in windows setting to “microsoft xps document writer”, I don’t know if this will resolve it or not.

@pravallikapaluri @lrtetala

Try running the program and let me know if the pop-up opens or not.

Ugh this mean more delay for the rpa process.

Because element exist will wait quite long time when the popup not going to appear.

Check by running the Process

Will look into this first

1 Like

Element exist will wait for 30 seconds only. That was not a bad time to wait.
The process will move parallel then there is not much delay.
It was better to handle the popup when triggering in between process.

Hope you understand!!

Ugh i have to test run & wait for the rpa process finish by hours due to hundreds of sheet processed hahah

1 Like

30 seconds x 500ish worksheets
hmm i don’t know

Make try with it If it was taking much time then ignore that one. @wija
Test it for 3 or 4 Sheets in the excel.

Hope you understand!!


If you use modern activities then in excel process scope you have option to disable display alerts

As suggested by others default printer also might negate the issue but in all systems that is to be done…

Parallel activity willbe a good alternative and for that element exists is not needed…you can use a click with continue on error property checked…so if the pop up comes up it is handled in parallel else the remaining activity continues…there would not be any delay involved

Hope this helps


3 or 4 sheets is unlikely the popup will appear.
for the popup to appear have to process massive sheets.

1 Like

Okay got it @wija

If any solutions nothing work, then try with my solution.

have to wait the popup appear first for me to be able to indicate the element.
after that i also have to consider the delay of element exist.

1 Like

Yes @wija

We have to indicate the element for element exist activity. If you are using modern activities then you can use the check app state activity.