Excel Delete Range bug? Range does not exist

Hey people I’m having an issue on an excel file, I have the file open within an Excel Scope and all the related activities within the scope. I do a ‘Read Range’ activity of the first sheet, do an assign MyDatatableVariable.row.count and assign the value to a variable, then I do a Delete range on that same sheet using “A2:G” + vMyCountVariable.tostring and this gives me the ‘Range does not exist area’.

I’ve also tested having the full range text with a variable first and placing that value in the Delete Range activity (for example, A2:G7) but this gives me the same result even though there is data within that sheet in the excel table.

Any fixes for this?

@cssc - I have tried delete data using “Delete Data” Acitivy from Bala Reva Excel acvities and it worked perfectly for me. You can see in the delete Range I have supplied “A1:C” idx.tostring and it deleted.

@cssc - Did that worked? If yes, could you please mark my post as solution

I can’t use third party packages on the current bot, do the native activities not work?

@cssc - Here you go

My Idx value is 3, so I put -1 so that i will delete A2:D2 range.

Before Deleting


After Deleting