Excel application scope not working

excel
activities
studio

#1

Hi Team,

I try to read my excel document(.xlsx) using excel application scope activity but its showing following error

My system and MS Office Details
System - 32 bit
MS office - 2010, 32 bit

And i tried same activity in another system and its working fine.
System - 64 bit
MS Office - 2010,32 bit

Kindly direct me a correct solution. I want this activity need to work on my system.

Thanks,
Rajasekar


#2

uncheck the visible option from properties of Excel application scope, then it works


#3

Hi Rajsekhar,

Thanks for the reply i checked this option(Unchecked visible option) but not working same error occur again.


#4

Try workbook activity instead of Excel Application Scope


#5

Hi @Rajasekar_M

Did you try deleting your packages and reinstalling them from the Package Manager? It might just help.


#6

Can you check if you can launch Excel from Run?
typing “excel.exe” and hitting enter?


#7

Do you have excel installed? If not, you will get this error and you should use the workbook activities instead


#8

I have a few other ideas.

—I would check if you have local admin rights on the machine. I have seen some weird things happen because IT deployed some faulty user policy settings.

—Open the file you are trying to access manually and verify if there are any popups or notifications that occur while opening the file. Such as a Trust notification or anything like that. If that is the case, then the solution will be a little tricky, because you might need to open the file using Open Application then close the notification, followed by the Excel scope. But, to be quite honest, I have seen this occur but can’t remember the approach I took to get around it.

Regards.


#9

Hi,

Im also encounter the same problem
I’m also already try to reinstall and repair the microsoft office but with no avail.
Is this because Ms Office version? Mine is using 2016 version and before upgrading to 2016 version (using 2007 version) it never encountered that error.

Is there any way we can check and send this error into uipath? Because in my case sometimes the popup occurs and sometimes not occurs but it will always occurs if we run the robot 2-3 times.

Thanks

BR

Aldo


#10

Hi prakurjoshi,
How to read excel data through workbook activity. i dont have option to open workbook.I installed required packages

Thanks,
Rajasekar


#11

Yes sir i did this. but not working…


#12

yes i can able to launch excel from run command.


#13

Yes i already installed excel. Can u please explain how to read excel data through workbook activities


#14

Hi ClaytonM

Thanks for the reply. I checked your points i didn’t get any security notification when open the excel.
And i provided all permissions for excel but no use.

Thanks,
Rajasekar


#15

Check if these articles can help :

https://answers.microsoft.com/en-us/msoffice/forum/msoffice_excel-msoffice_custom-mso_archive/8002801d-automation-error-library-not-registered/5717123b-4c0b-4a3d-8bb5-7d0fe84e6ac9

https://excel.tips.net/T002952_Library_Not_Registered_Error.html


#16

I was talking about this -


#17

Instead on excel application scope, you may alternatively try the “Select file” option and read the details via “read range” option.
I am also accessing an excel file as input, however, by not using the “excel application Scope”


#18

Hi Priya,

Thanks for the replay. Now i can able to access excel file (.xlsx) without excel application scope activity.